Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-02-2003, 09:03 AM
Registered User
 
Join Date: May 1999
Location: Calgary, Alberta, Canada
Posts: 190
Dome light not turning on when driver's door is opened.

In my 1988 300E I am having a problem with my dome light not turning on when I open the driver's door. All the other doors it works fine. I can hear a click from the relay box when I activate the pinswitch for the door. Any ideas where to start. I did a search and found some info on a W126, not sure if the info would apply to mine.

TIA,
Steve
__________________
1997 E320
1990 Nissan 300ZX Twin Turbo (Stage X+)
Reply With Quote
  #2  
Old 02-02-2003, 09:59 AM
bjcsc's Avatar
Registered User
 
Join Date: Nov 2002
Location: Charleston, SC
Posts: 672
The switch is the likely problem. Pull it out and have a look at it. You can also remove the passenger side's working switch and see it it operates from the driver's side. Sometimes you can clean the pin switches out, sometimes not. I would start by working the switch with my finger fifty times or so while watching the light. Then I would try the pass. side switch.
__________________
1982 Mercedes-Benz 300CD
1982 Mercedes-Benz 240D - stick
Reply With Quote
  #3  
Old 02-02-2003, 11:48 AM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
These are a bit different. Pull the dome lamp switch out, check for power. If you have it, bridge the wires and if the lamp comes on, you've got a bad switch. If you have no power there is a relay that powers the seatbelt warning system and the l/f door switch. Its behind the cluster and really is no fun to replace.


Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #4  
Old 02-02-2003, 11:19 PM
Registered User
 
Join Date: May 1999
Location: Calgary, Alberta, Canada
Posts: 190
I tested the switches on the driver's door with a continuity meter and they both seem to work fine. Also, the seatbelt buzzer is working fine when you turn the key. I am getting power I assume because as I said, the light works in other positions and when any of the other doors are open.

Steve
__________________
1997 E320
1990 Nissan 300ZX Twin Turbo (Stage X+)
Reply With Quote
  #5  
Old 02-03-2003, 12:47 PM
csnow's Avatar
Registered User
 
Join Date: May 2002
Location: Mass
Posts: 1,127
I do not have the solution, but I do have exactly the same problem. Empathy, right?

Door switches are fine. Seatbelt warning operates.
__________________
1986 300E 5-Speed 240k mi.
Reply With Quote
  #6  
Old 02-03-2003, 02:08 PM
jbaj007's Avatar
Registered User
 
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
I had the 4 position light ( but without the temp. sensor/grill) in my 300SD, as a P.O. upgrade. Same symptoms,went thru the same diagnostic tree. Found that the IC in the light itself was the cause...replaced light fixture...cured. FWIW.
__________________
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote
  #7  
Old 02-05-2003, 08:04 AM
Registered User
 
Join Date: May 1999
Location: Calgary, Alberta, Canada
Posts: 190
Thanks joe p!

I pulled the dome light and found that there was no power coming up there from the driver's door. So I chased down the seatbelt warning buzzer and pulled it out. I took it apart and there was two places where you could see the solder wasn't making good contact. I tested the relay's circuit with my continuity tester and found it was not complete. Got out a soldering iron and heated up the two open parts, and it works as good as new. It would be tough thing to solve without help from others on this site.

Thanks again,
Steve

P.S. I think older MBs should have a soldering iron in the toolkit in the trunk.
__________________
1997 E320
1990 Nissan 300ZX Twin Turbo (Stage X+)
Reply With Quote
  #8  
Old 02-05-2003, 10:13 AM
csnow's Avatar
Registered User
 
Join Date: May 2002
Location: Mass
Posts: 1,127
Great news!
So where exactly is this thing located?
__________________
1986 300E 5-Speed 240k mi.
Reply With Quote
  #9  
Old 02-05-2003, 02:22 PM
Registered User
 
Join Date: Jan 2001
Location: California
Posts: 2,068
It's behind the gauge cluster, to the right. Small box about 1" x 1" by 2". Part number 004-545-07-32. If this goes out, your buzzer will still work, but the seatbelt display up by the dome light (and the dome light itself) won't work when the driver's door is opened.
Reply With Quote
  #10  
Old 09-02-2003, 01:34 PM
Marcb's Avatar
Registered User
 
Join Date: Jan 2003
Location: Centralia, Washington
Posts: 351
On my 87 300D, I'm having a similar problem. If the relay is bad, would the seatbelt buzzer ring all of the time when the car is running WITHOUT the seatbelt buckled? I have a constant buzzer and no overhead lights in the upper console.
__________________
--------------------------------------------
1960 MB 190Db w/ full sunroof
1985 Toyota Pickup
2006 Honda Odyssey EXL R&N
2001 VW Jetta GLS TDI
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page