Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-08-2003, 09:47 PM
elau's Avatar
Registered User
 
Join Date: Nov 1999
Location: MD.
Posts: 1,725
Which fuse? Help!!

My wiper on the 87 300E quit working the other day and I suspected that it must be fuse related. I opened the fuse box and saw that the connector of the #2 (colour red) fuse was cooked. At the same time I also noticed the fuse for the fog light(colour white) was also fried. Went to Advance Auto and they don't carry the type of fuse I need.

Where can I get the fuse except from the dealer? I went to Partshop but there is no picture on the fuse kit. How do I know it is the right fuse? Are they all the same even some are red and some are white.

Need help and hope it won't rain in the next few days. I don't want to pull the SL out of the garage unless I absolutely have to.
__________________
95 R129
04 Infiniti G35.5 BS
10 X204
Reply With Quote
  #2  
Old 02-08-2003, 10:19 PM
Jason M.
Guest
 
Posts: n/a
Advance does carry them, make sure to look yourself on the electrical isle... I know for a fact that they stocked them as recently as 1 year ago.

Advance/Discount has a terrible habit of employee turn over with most employees having no experience in parts, they therefore are quite unfamiliar with their inventories

Try an Autozone, save yourself the trouble
Reply With Quote
  #3  
Old 02-09-2003, 09:24 AM
Registered User
 
Join Date: Apr 2002
Location: Surrey, Uk
Posts: 254
The colours show the different current ratings. It's raining outside so I'm not going to check them out but I think the ratings are marked on them also.
__________________
Mick J
'08 Chrysler 300CRD (MB OM 642 engine)
'95 E220 estate
'89 230TE (R.I.P.)
Reply With Quote
  #4  
Old 02-09-2003, 07:41 PM
elau's Avatar
Registered User
 
Join Date: Nov 1999
Location: MD.
Posts: 1,725
Got it fixed! Thanks for the info. I looked at the fuse and there is a number stamped on it . Took it to Advance again and talked with someone has more experience than the guy I talked to last and this time I got the right fuse. The wiper works and so is the fog light.

Thanks again for the help.
__________________
95 R129
04 Infiniti G35.5 BS
10 X204
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page