Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-23-2003, 04:28 PM
Registered User
 
Join Date: Nov 2002
Posts: 11
560sel-no oil pressure

The other night while driving my car, I hit bottom pretty hard comming out of a parking lot. Almost immediately, I started hearing a bearing knock, but only when braking hard. Next morning, I went to start the car, and there was no oil pressure at all. Any ideas on what I might have done?
Reply With Quote
  #2  
Old 02-24-2003, 02:11 AM
Mattman
Guest
 
Posts: n/a
Sounds to me like the oil pan got bashed up into the oil pickup tube. You are going to have to pull the pan off and have a look see.

Matt.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page