Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-26-2003, 02:21 AM
Posts: n/a
all power or none!!!!!!!

I have a 91 420sel. It will drive fine and then it will just loose all power. It will kick in again and drive fine again for a few miles and then just loose all its power. some times it will loose power all the way till I stop and just die. Then I will start it and will die again. After a few times of trying to start it, it will stay started and will drive fine for a few more miles and will do the same thing again. Please help!!!!!!
Reply With Quote
Old 02-26-2003, 05:03 AM
Registered User
Join Date: Jan 2003
Location: Epsom Downs, England
Posts: 152

Plumb-in a fuel pressure gauge to the fuel rail.

When the engine dies, check if the fuel pressure is still there. If not, you've found the problem (pump, filter, furl lines etc).

If the pressure is still there it's more likely to be electrics.
Paul Gibbons
'93 320CE
'73 Jensen Interceptor (Resting)
Giant Full Sus Mountain Bike
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:41 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page