Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-02-2003, 03:40 PM
GDJ GDJ is offline
Registered User
Join Date: Feb 2003
Posts: 20
heated seats on '91 SEL: no heat

Lights are active on 3 of the 4 seat heating switches, but no heat.
Checked fuses and plugs under seats....all ok.
Any knows syndromes or suggestions?
Reply With Quote
Old 03-02-2003, 08:09 PM
MikeTangas's Avatar
Senior Member
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Are you the original owner, or recently acquire the car? If original, or a problem that recently came on I'm not sure where to start. You do get one light when pushing at the top of the switch and two when pushing the bottom (1 = low power, 2 = high power), correct?

On my 560SEL the seats heater take a minute or so before heat is felt, then the heat builds until toasty warm. Maybe you aren't waiting long enough before deciding the heater isn't working.
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon least its a diesel

Non illegitemae carborundum.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:29 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page