Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-07-2003, 09:43 AM
Posts: n/a
Question a/c electrical problem

I have an 85 300D with no power to the compressor. The low pressure switch is working (comes on and off with an a/c switch selected.) Can anyone tell me the electrical path into and out of the climate control for the compressor? Is there another switch after the climate control before the compressor? If there is, is there a way to bypass them and would it be safe to do so?

Thanks for any help,
Reply With Quote
Old 05-23-2003, 01:43 PM
Posts: n/a
compressor not working

Try turning the a/c on with the car running and then disconnect the single post wire connector on the water temp sensor located where the top radiator hose goes into the engine. Then look to see if the compressor engages. It worked for me. If this works, you need a new temp sensor.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:58 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page