Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-09-2003, 11:28 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
'95 E320 Wagon: No Turn Signals or Flashers

Help!

On the road, turn signals and flashers failed. Is this/could this be fuses or indicate a relay? Any help would be appreciated.

Keep me posted,
Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #2  
Old 03-10-2003, 02:28 AM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Turned off the car for about two hours. Started it up and now the flashers and signals work again. What is this? Anyone every have this problem?

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #3  
Old 03-10-2003, 05:26 AM
Registered User
 
Join Date: Jan 2002
Location: England
Posts: 1,841
I believe if the hazard flasher switch is removed / faulty, it will cause hazards and turn signals to stop working.
__________________
190E's:
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
http://www.maylane.demon.co.uk/190esmall.jpghttp://www.maylane.demon.co.uk/190esmall2.jpg
Reply With Quote
  #4  
Old 03-16-2003, 03:55 AM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Now wiper switch, turn signals and flashers won't work intermittently. Is this related to the turn signal stalk?

I checked the fuses and all seem good.

Anybody experience this? Any suggestions as to where to look?

thank you in advance,


Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #5  
Old 03-16-2003, 01:27 PM
Registered User
 
Join Date: Jun 2002
Location: Chicago Area
Posts: 97
You need a new combination relay - It is located in the compartment aft of the fuse box on the LH side of the engine compartment - about $50 or so.

All of the functions that you describe are controlled by that relay.

Easy to change - DIY task.
__________________
Tom Latos
2002 E320
1995 E320 Sold at 288kmiles
Reply With Quote
  #6  
Old 03-16-2003, 01:39 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Thanks Tom. Very weird to have happen!

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page