Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-11-2003, 11:21 PM
Posts: n/a
CLK 320 Electrical Question

I have a CLK 320 Cabriolet, and for some odd reason, dont ask me, but the speedometer and gauge cluster stopped responding, the screen still works, but the mph, tach, dont move, along w/ the fuel level and water temp.

Well sure enough, i blew number 19 fuse (5 amp fuse), the car drives fine, except the fan stays on, so i pulled the plug for the fan, apparently the alternator stays on at 14.0 volts,

i was wondering if there was any downside to driving the car tonight (the shops are closed and cant find a place w/ a fuse until tomorrow)

What else is on this circuit, and will my car be totally safe driving it tonight?

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:29 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page