Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-12-2003, 02:22 PM
Bungee
Guest
 
Posts: n/a
Bouncing speedometer

The speedometer in my 450sel bounces like a rabbit on crack. Sometimes it craps out altogether.

It appears that, at the very least, the cable is binding. Tthe cable is extremely sensative to positioning ... moving the cable changes how the speedometer works--it makes it work better, worse, or sometimes not at all.

Right now the speedometer barely moves.

I read the posts suggesting lubricating the cable. But other than that, what do you suggest for diagnosing and solving the problem? The cable seems too touchy, and it's not safe trying to find the "right" position while driving!
Reply With Quote
  #2  
Old 03-12-2003, 02:55 PM
MikeTangas's Avatar
Senior Member
 
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Best bet is to replace the cable entirely. The cables are exact length, which will require you to route through the original locations as there is no extra slack. Replacing my cable cured the bouncy speedo on the 4.5.
__________________
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon TDI...at least its a diesel

Non illegitemae carborundum.
Reply With Quote
  #3  
Old 03-12-2003, 04:13 PM
Bungee
Guest
 
Posts: n/a
Would you suggest replacing both top and bottom cables?

I've always assumed the bottom cable to the tranny would be a bear to install.

Thanks
Reply With Quote
  #4  
Old 03-12-2003, 08:10 PM
MikeTangas's Avatar
Senior Member
 
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Didn't know you had dual cables. Do you have one running to the cruise and the other from the cruise to the speedo head? I'd bet the lower cable is bad, but would probably change both.
__________________
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon TDI...at least its a diesel

Non illegitemae carborundum.
Reply With Quote
  #5  
Old 03-13-2003, 12:03 PM
Zeus's Avatar
Moderating, Eh?
 
Join Date: Feb 2000
Location: Canada
Posts: 1,774
Only recently, my speedometer has begun 'chattering' slightly. It only does this when it's cold out. Seriously. The past few weeks, when it has been -15C or colder, the speedo chatters. It happens at startup after the car has been out all night. Once the car is warm, the chattering is gone and the speedo holds steady.

Is this an early sign that my cable is going? Or is this normal in very cold conditions. Just curious...
__________________
Chris
2007 E550 4Matic - 61,000 Km - Iridium Silver, black leather, Sport package, Premium 2 package
2007 GL450 4Matic - 62,000 Km - Obsidian Black Metallic, black leather, all options
1998 E430 - sold
1989 300E - 333,000 Km - sold
1977 280E - sold
1971 250 - retired


"And a frign hat. They gave me a hat at the annual benefits meeting. I said. how does this benefit me. I dont have anything from the company.. So they gave me a hat." - TheDon
Reply With Quote
  #6  
Old 03-13-2003, 01:49 PM
moedip
Guest
 
Posts: n/a
Zeus - get that problem up here in cold country all the time. When the car is cold the needle bounces all over the place and you can hear the chatter. Real bad at -20 to -30 outside. As the car warms up the speedo starts to work normally. Problem does not occur when it gets warmer out. Solution: Pull the speedo cable out of it's sheath and wipe it clean with solvent. Liberally cover it with white grease (or if you have it - speedo lube) and re-insert it back into the sheath. Usually lasts for about 2 years before it needs fresh cleaning and lubing up here. On the bright side - when the needle is bouncing all over the place you can at least see what it looks like at 145 mph!!!
Reply With Quote
  #7  
Old 03-17-2003, 03:11 PM
Zeus's Avatar
Moderating, Eh?
 
Join Date: Feb 2000
Location: Canada
Posts: 1,774
Cool, thanks moedip! I may try that, or I may simply replace the whole cable.
__________________
Chris
2007 E550 4Matic - 61,000 Km - Iridium Silver, black leather, Sport package, Premium 2 package
2007 GL450 4Matic - 62,000 Km - Obsidian Black Metallic, black leather, all options
1998 E430 - sold
1989 300E - 333,000 Km - sold
1977 280E - sold
1971 250 - retired


"And a frign hat. They gave me a hat at the annual benefits meeting. I said. how does this benefit me. I dont have anything from the company.. So they gave me a hat." - TheDon
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page