Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-07-2000, 02:32 AM
JMike
Guest
 
Posts: n/a
1990 190E 2.6. My engine temp gauge shoots right to the top of the gauge just minutes after the car is started. I changed the sending unit located on the engine. Didn't help.
An electrician said that the gauge might be broken and should be replaced. The dealer will only sell the whole dash set, speedo, clock, tach and all. About $500. Will appreciate input.
Reply With Quote
  #2  
Old 01-07-2000, 09:45 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
How do you know the engine isn't overheating? If it did it instantly, I would think the gauge is faulty.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #3  
Old 01-09-2000, 02:00 PM
Aaron's Avatar
Moderator
 
Join Date: Aug 1999
Location: Cincinnati, Ohio
Posts: 1,935


Did the temp come back down after driving for a few miles? If so, it might be a sticking T-stat.


------------------
Rgds,
Aaron Greenberg
MB technician
Precision Motorcars, Cincinnati, Ohio
'67 250SE Cabriolet
'77 450SL
'79 6.9
'80 300SD
'85 380SE
'89 420SEL
'93 300E 2.8


Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Engine Dead???? Breckman99 Diesel Discussion 17 05-10-2005 12:26 AM
560SL External Temp Gauge jml214 SL Forum 1 04-21-2004 06:29 PM
Oil Pressure Gauge - pegged when ignition 'ON' and engine is off - 95 E320 71Rcode Tech Help 4 03-07-2004 03:36 PM
LOGIC REQUIRED -Engine Temp What Is Normal?????? moedip Tech Help 29 07-13-2002 01:53 AM
Engine Temp High psabado Tech Help 1 08-30-2001 07:00 PM



All times are GMT -4. The time now is 03:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page