Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-13-2003, 12:50 PM
Joseph_H's Avatar
Registered User
 
Join Date: Nov 2002
Location: Texas
Posts: 231
warning light for my light bulbs went on??

The orange warning light for my light bulbs/lamps went on today when i pressed the brake at a stop sign then went off and didn't come on again at the next stop sign. Is this a sign that I am about to have a bad lamp/bulb somewhere? or is there already a bad bulb? Why would the warning light come on only once? thanks.
__________________
Joe95E420
Reply With Quote
  #2  
Old 03-13-2003, 01:52 PM
Registered Diesel Burner
 
Join Date: Aug 2001
Location: Northern Virginia
Posts: 2,911
The way my car's light-bulb warning light works is that, once triggered, it will stay on until the ignition is cycled through off. I had a bad brake light bulb, and the warning light would come on when I touched the brakes for the first time in the morning, and then stay on.

So, I recommend you check on two things:

1) Make sure the light-bulb warning indicator in the dash still comes on when the ignition key is turned to ON, but before starting the car.

2) Check all three of your brake lights.

----------

One scenario I'm thinking of is that your light-bulb warning indicator bulb has shot.



Ken300D
Reply With Quote
  #3  
Old 03-13-2003, 02:17 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
If you don't have a burned-out bulb, then check to make sure you don't have corrosion at one of the bulb holders and that you have compatible bulbs installed. Have you replaced any recently?

Follow the recommended bulb brand/types. Some cheap after market bulbs "upset" the bulb warning system.

Keep us posted,

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #4  
Old 03-13-2003, 02:25 PM
Joseph_H's Avatar
Registered User
 
Join Date: Nov 2002
Location: Texas
Posts: 231
Thanks Guys

Last time this happened I had to replace a R-turn signal bulb. I usually don't buy the bulbs from the dealer as i can find same ratings elsewhere much chaper and closer to home. I'll check it out and provide update.
__________________
Joe95E420
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page