Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-13-2003, 11:08 PM
elau's Avatar
Registered User
Join Date: Nov 1999
Location: MD.
Posts: 1,725
300E idle problem

Help!! My 87 300E idles extremely rough after sitting still in traffic for an extended period of time. The car vibrated badly, and the engine felt like it was going to cut out (although it never did). The idle speed, however, remained pretty much at 1,200 rpm. When I applied gas when the traffic began to move, the engine acted like not all cyclinders were firing, and there was not much power to get up to speed. I can hear knocking from the engine if I applied too much gas. But as soon as it got back to crusing speed, the power band retuned and the vibration ceased.

What would be the cause? It happened frequently when I got stuck in traffic. I am afraid one of these days the car will just quit and I will be the cause of a major traffic jam in the Washington beltway.
95 R129
04 Infiniti G35.5 BS
10 X204
Reply With Quote
Old 03-13-2003, 11:56 PM
Registered User
Join Date: Dec 2001
Posts: 565
Went to search engine and keyed in "300E idle". Came up with this:

Lots of possibilities. Find a shop versed in "diagnosis" and not parts replacement. An hr. or two of shop labor by way of a good tech should get to the heart of the matter.

Good luck.
Reply With Quote
Old 03-14-2003, 12:54 PM
Registered User
Join Date: Oct 2002
Location: Ontario
Posts: 37
Would it be a faulty fuel pump?

There maybe some moisture in your fuel tank. Once I sent my wife's BMW to a mechanic, paid $500+ for a new oxygen sensor and tune up that did not fix the problem similar to yours, a bottle of $15 Fuel System Treatment did the work.

Good luck.
Reply With Quote
Old 03-14-2003, 08:56 PM
J.HIDALGO's Avatar
Registered User
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785

'86 300E
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:42 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page