Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-18-2003, 03:43 AM
Registered User
Join Date: Feb 2003
Posts: 24
Exclamation 1991 500sl hesitation during cold start

My SL always hesitates for a couple of seconds too long when I turn the key of the ignition. When it does start, it is a very weak start. This always happens when the weather is cold(even though I'm in Soutern California and its not that cold) The car then hesitates during every stop and go acceleration until it is warmed. It also has a very strong odor of gas, until its warm. Could this be the distributer, spark plugs, carbon build up?
Thanks for the help,
Reply With Quote
Old 03-18-2003, 07:25 AM
it leaks, its german
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
I'd look at the coolant temp sensor, state of tune, sticky pivot hinge on the a/f sensor and if it skips cold and on hot soak starts, injector leaks.

Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page