Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-13-2000, 01:57 PM
Wing_Nut
Guest
 
Posts: n/a
First I'd like to thank mercedesshop for the quick responses to my questions, they have been very, very helpful.
Now I have a speedo question. Speedometer & Cruise were working fine, then while driving the speedo went dead. Not really sure where to start. I know there is a control box under the dash, and the wiring harness that goes to the tranny. But after reading the postings, there seems to be several other areas involved as well. If someone could offer up a starting point to begin eliminating possibilities I would really, really appreciate it.
Thanks for your time,
Peter Kalloday

------------------
Wing_Nut
82"300SD
Reply With Quote
  #2  
Old 01-13-2000, 10:11 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Look very carefully at the fuses. There could be a hairline crack in one.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #3  
Old 01-14-2000, 12:28 AM
Wing_Nut
Guest
 
Posts: n/a
I've already replaced all the fuses, and I've cleaned the contact points with a light grit sandpaper. I've got good power on both sides measured with a volt meter. I appreciate the information, but I do believe it is something a little more involved.
Once again, thank you all for your time.
Peter Kalloday

------------------
Wing_Nut
82"300SD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise problem 85 300SD (126) Bobthebuilder Diesel Discussion 2 11-03-2004 01:23 AM
Request for Info of Cruise Repair 300SD regsatx Diesel Discussion 1 10-20-2004 05:54 PM
WTB part of a later w123 speedometer JHZR2 Mercedes Used Parts For Sale & Wanted 2 12-17-2003 03:01 PM
84 300SD Cruise Control Question jake1222 Diesel Discussion 10 11-05-2003 03:08 AM



All times are GMT -4. The time now is 12:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page