Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-14-2000, 08:47 PM
Registered User
Join Date: Sep 1999
Location: montreal,quebec,canada
Posts: 53
hello all
anyone tell me how i can check if the radiator fan clutch is working ok????
my engine does not go above 60 deg C and in minus 20 deg it is really uncomfortable in the car.....i suspect the fan because i have changed the thermostat and it made no difference.
Reply With Quote
Old 01-14-2000, 11:28 PM
Posts: n/a
I was going to ask the same question because at speeds around 70mph, mine sounds like a WWII bomber ready to take-off and am thinking the fan clutch isn't slipping. I'll keep checking, but in case I miss the reply, please forward the response to Many thanks!
Reply With Quote
Old 01-15-2000, 01:30 AM
Join Date: Jan 2000
Location: Indpls.,IN. USA
Posts: 84
Your fan clutch should have no effect on your ability to heat the interior of your car. Look into things like a restricted heater core or a failed auxillary coolant pump. It is also possible to over protect your coolant, in which case it becomes too thick and at the extreme it can even cause your engine to overheat. As far as checking a fan clutch you must bring the engine to operating temp. and then with the hood up hold the engine RPM to about 2500. The fan will noticeably change sound and speed after several minutes, this may be difficult to do outdoors in cold weather.
Reply With Quote
Old 01-15-2000, 09:01 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The fan clutch can fail in a few ways. One is that the fan can lock up. If so, it will make some noise like an airplane ready to take off. The other way is to freewheel. This will cause the car to run hot.
IF yours is not heating well, try a hotter thermostat. Be sure the mono-heat valve and the auxillary water pump is working...The mono-valve is cheap and they fail alot with no/little heat complaints.

1981 280GE SWB
1987 16V

[This message has been edited by Benzmac (edited 01-15-2000).]
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fan clutch - M104 on M119 anyone done it? moruzzi Tech Help 4 05-18-2004 06:04 PM
Fan clutch failure - Killed the radiator!!! moruzzi Tech Help 3 05-16-2004 06:53 AM
Fan Clutch HELP.. Merc1 Tech Help 13 08-01-2003 01:51 AM
Auxiliary Fan Question JBoggs Tech Help 9 07-30-2003 10:07 PM
Fan Clutch.. Help Merc1 Tech Help 1 07-28-2003 09:08 PM

All times are GMT -4. The time now is 01:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page