Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-19-2003, 07:20 PM
Posts: n/a
engine revs up while driving

I have an automatic 88 300e. When I'm driving along, the engine revs suddenly increase (without my help) but I do not speed up. It seems as if I'm in neutral. I happened to me twice today in 4 trips

When I drop the transmission into the next lowest gear (3), it seems the tranny reengages. This problem does not appear in gear 3, the gear just below D, only when I'm in Drive, and only when a gear change ought to have occurred because the appropriate revs were met.

The problems also disappears sometimes when I take my foot off the gas and let the revs drop.
Reply With Quote
Old 03-19-2003, 11:21 PM
rdanz's Avatar
Registered User
Join Date: Sep 2002
Posts: 1,158
Smell your tranny fluid and if it smells burnt change filter and fluid that mite help. Sounds like your tranny is on its way out.
Reply With Quote
Old 03-20-2003, 12:36 AM
Senior Member
Join Date: Sep 2002
Location: So. Calif.
Posts: 323
Reply With Quote
Old 03-20-2003, 07:45 AM
Posts: n/a
Thanks guys.

Would it make any difference to your replies if I told you that the problem is not there when I tramp down the accelerator-no problem getting into passing gear. The car automatically and smoothly switches up from there.
Reply With Quote
Old 03-20-2003, 09:58 AM
Posts: n/a
The car has 100,000 miles on the odometer.
Reply With Quote
Old 03-20-2003, 10:56 AM
Posts: n/a
Thanks for replying.

The mileage is right. I'm the second owner. I've had the car 3 years and I've put on 22,000 of the 100,00 miles.

I've never had the tranny serviced. I will do that this week. I noticed the ATF was low-maybe as much as half a litre! It's been topped up. It had a flaring on my first trip on the highway this morning since top up, but has been good since. But it will be serviced.

Thanks again.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page