Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-21-2003, 01:48 PM
demoto
Guest
 
Posts: n/a
Help!

Here's the deal ... had to replace the head on my 1990 350SDL ..,
that went smoooth . trouble is now it won't start . My glow plug indicator does not come on with ignition on "BUT" with a test light grounded to glow plugs indicate current reaching the plugs .. when the preglow timer kicks off , then the indicator light on the dash comes on ?????? Mind you the vehicle started fine here prior to this operation :-) here in Illinois .., even with this glow plug indicator problem .

Also being careful in not disturbing the timing chain with head off ...I'm wondering if it is possible I upset the ignition pump timing with the head replacement . Manuals for this model is like finding cotton balls in a snow storm !! If anyone can provide me with the specs for IP timing and any other info .....It would be much appreciated !
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page