Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-21-2003, 03:39 PM
Registered User
 
Join Date: Feb 2003
Location: Miami, Fl
Posts: 23
Question Power steering noise??

Some info: 1999 E-320 (W210) with 66000 miles.

Question:
When I turn on the car a strange noise is made by the power steering system. The noise sounds like the purring a cat would make (Pbrrrrrrrrrrrrrrr!). It only happens once after turning on the car, lasts approximately one second, and does not happen every time (only after the car has been sitting for a while).
At first I thought it could be lack of Power Steering fluid, but the reservoir has got the right amount of Power Steering fluid. There are NO power steering fluid leaks and no steering abnormalities.
ANY IDEAS on what this could be??????????

yamil
Reply With Quote
  #2  
Old 03-25-2003, 04:00 PM
Registered User
 
Join Date: Feb 2003
Location: Miami, Fl
Posts: 23
Can anyone offer any input?
Reply With Quote
  #3  
Old 03-30-2003, 12:42 AM
Rob2000
Guest
 
Posts: n/a
You might try tightening the power steering pumps belt. Down by the pump the belt can be tightened by loosening the bolts, slightly, and then readjusting it to factory specs. Im not sure, but something like 1/4 to 3/4 inch deflection. Probably somewhere in-between.

If you get a fluid on the belt and pulleys, and the belt isnt perfectly tight, then what you describe can be exactly what occurs. Easy fix. Can be a knuckle buster depending on the location of the power steering pump though.

Try tightening your belt and then hit that baby with a mild pressure wash to get rid of any oil, gook, etc.


Rob
Reply With Quote
  #4  
Old 03-30-2003, 07:40 AM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Location: New Jersey, U.S.A.
Posts: 2,461
Hey Rob, the vehicle in question has an automatic belt tensioner. It can't be tightened. Yamil78, is the P/S fluid at the correct level. Make sure it is before you do anything else. Also, have you had the car to an MB dealer? 210's are notorious for a variety of steering noises. Sometimes the column rubs the firewall boot/grommet(easy fix). Sometimes it's a pressure noise that requires replacement of the steering rack. In this case, the noise is usually worse in cold weather. I've seen both cases dozens of times.
Reply With Quote
  #5  
Old 03-31-2003, 02:22 PM
Registered User
 
Join Date: Feb 2003
Location: Miami, Fl
Posts: 23
Thanks for the inpuit guys. Here is my response:
- The P/S fluid level is not LOW. It is exactly where it should be.
- There is a belt spring loaded belt tensioner.
- I don't think the Steering column needs replacement because I have never felt any play when turning, never sensed any slack in the steering, never had any rattling in the column, etc...

Is it possible that this Purring noise is being made by the actual P/S pump?? Maybe I am confused here, but it seems to me that it happens as the P/S fluid starts to move around in the system.

yamil
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page