Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-21-2003, 05:38 PM
Registered User
Join Date: Sep 2001
Location: scottsdale, AZ
Posts: 40
Question '92 400 se runs Perfectly....until it Runs Rough!!.......

My '92 400 se runs great and accellerates fast right up through 80 mph! the problem is that when i am going about 40 mph , and i crack the throttle on and off, sometimes the engine will cut out, like it lost fuel, or the air fuel mixture is incorrect. it feels like i am running on 4 cyclinders for a moment, and then it will begin running fine again. got any ideas? thanks in adavnce. i have greatly appreciated your advice in the past. thx, mike 602 616 2974 phoenix.
Reply With Quote
Old 03-21-2003, 08:42 PM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Possibly one of the distributor caps or rotors are bad, this vintage was known for that. If one of the rotors is bad, that's exactly how it would act too (like running on 4 cylinders) because that's exactly what it would do. Or possibly a coil, there are 2 of them, so you would have the same result as a bad cap or rotor.
Is it temp or weather related at all? Only happen with the engine hot or cold?

Reply With Quote
Old 03-22-2003, 12:24 AM
Registered User
Join Date: Sep 2001
Location: scottsdale, AZ
Posts: 40
you're right. the weather had rained here for a week, and the mechanic said that we had a cracked distributor cap. how about the possibility of a bad asr sensor switch on one of the wheels, i heard that it may cut off the fuel if one of the rear wheels was not sensing the correct reveloutions relative to other wheel so n the car? thx, mike
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:11 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page