Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-25-2003, 01:08 AM
Mark Karlsson
Posts: n/a
Question E420 idling too fast

Hello: I just replaced the throttle valve assembly on a '94 E420. The reason I replaced it is I had a check engine light that came on. I cleared the code and I would get an idle speed control code which would recur after about three days. After replacing the throttle valve assembly, the car would idle at 1500 RPM. I removed the new throttle valve assembly, checked for misplaced hoses and gaskets, found none so I reinstalled the original throttle valve assembly. At this point the car idled normally. I suspect a defective part.

Does anyone have any thoughts on this? Do I have a bad brand new throttle valve assembly??

Any help is greatly appreciated!

Reply With Quote
Old 03-25-2003, 07:34 AM
it leaks, its german
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
you've got to readapt the throttle stops, find a shop with a HHT capable of doing this.

Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:59 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page