Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-26-2003, 09:09 PM
Registered User
 
Join Date: Jan 2002
Posts: 165
post-oxygen sensor replacement..

I've been doing a complete search on all oxygen sensor related issues, but I just need a response to this one question:

After I replace the sensor, does the fuel/air mixture readjust itself back to healthy spec, or are there any further steps I need to take to make the car run correctly? Does clearing the #2 code do this for me. or...is there something more I need to do?

Thanks!
__________________
1995 MB E320 Wagon
2001 BMW 530i
2007 MINI Cooper S (!)
Reply With Quote
  #2  
Old 03-26-2003, 10:56 PM
chicago124
Guest
 
Posts: n/a
Hi,

As long as you didn't fool around with the mixture, it should be back at spec. Yes, you'll have to clear the code.

Regards,
Reply With Quote
  #3  
Old 03-27-2003, 11:39 AM
Registered User
 
Join Date: Jan 2002
Posts: 165
thanks, that's what I was thinking.
__________________
1995 MB E320 Wagon
2001 BMW 530i
2007 MINI Cooper S (!)
Reply With Quote
  #4  
Old 03-27-2003, 12:58 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,777
Your car is HFM-SFI . You couldn't fool with the mixture if you wanted too.. It is non-adjustable .
It will adjust itself..
Reply With Quote
  #5  
Old 03-27-2003, 01:03 PM
Registered User
 
Join Date: Jan 2002
Posts: 165
Thanks, Arthur!

The reason I ask is that my indy is asking $470 for diagnosis-replacement-recheck system!!!

It's a bit tight right now, so I was just about floored when he gave me this estimate. I'm gonna pay him for diagnostic time, then wish him good day, replace it myself, then reset codes.

90% sure this will fix CE light, sluggish accel. and poor MPG.

Yikes!
__________________
1995 MB E320 Wagon
2001 BMW 530i
2007 MINI Cooper S (!)
Reply With Quote
  #6  
Old 03-27-2003, 06:04 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
I think you might need to find a new mechanic.

$470 for what?

If you still have a CE light illuminated, you can clear it yourself in about 6-8 seconds.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #7  
Old 03-27-2003, 06:17 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
The O2 sensor is a reasonable replacement item as it often is stated to be replaced at 60k miles anyway. We never do it because its function is so easily tested, but often will when there is such a code and the miles are right.

The most important thing to watch when dealing with O2 sensor codes is the adaptation numbers. These should change if the sensor was a problem.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #8  
Old 03-29-2003, 10:38 AM
Registered User
 
Join Date: Jan 2002
Posts: 165
Thanks Paul and Steve,
At 112K, I think its time for this item to be replaced, which leads me to my next issue:

Wow! This is ONE TOUGH nut, how the heck do I get this thing loose without stripping it or snapping it right off?

I tried yesterday using combo of penetrating oil(soaked for about 4 hours) and warming up the pipes, but no go. It was so tight that my sensor remove socket actually slipped, rounding off the corners somewhat, but not a lost cause yet.

So I let it sit all night with pen. oil on it and going to try again today. Should I just decapitate the old one so I can get a shallow 22mm socket on it or...what?
__________________
1995 MB E320 Wagon
2001 BMW 530i
2007 MINI Cooper S (!)

Last edited by miktvk; 03-29-2003 at 12:58 PM.
Reply With Quote
  #9  
Old 03-29-2003, 01:00 PM
Registered User
 
Join Date: Jan 2002
Posts: 165
Unhappy Anyone?

Am I the only one to have had so much trouble extracting the sensor?

Any advice much appreciated...
__________________
1995 MB E320 Wagon
2001 BMW 530i
2007 MINI Cooper S (!)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page