Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-29-2003, 03:15 AM
Surbenzolot
Guest
 
Posts: n/a
started my car then bang

I started my 94 C280 and then it sounded like it was gonna stall and then I heard a bang sound comming from the engine then it went to normal idle.Can someone tell me want went wrong.
Reply With Quote
  #2  
Old 03-29-2003, 05:01 AM
sunil190e-1.8's Avatar
Registered User
 
Join Date: Jun 2002
Location: uk
Posts: 236
looks like you had a backfire causing the the bang!

definately not a cruise missle!
Reply With Quote
  #3  
Old 03-29-2003, 08:39 AM
Surbenzolot
Guest
 
Posts: n/a
What causes a back fire? How can I prevent that
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page