Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-04-2003, 11:04 AM
Registered User
Join Date: Apr 2003
Location: Savannah, GA
Posts: 5
Unhappy PLEASE HELP! 88 560SL losing power at 2500 rpm's

I've sent one message out. I am hopeful that someone out there has had a similar problem. Mechanics want to start rebuilding motor one part at a time.
The power loss occurs around 2500 RPM's and only happens when you open up on the throttle.
In parked position, I reved the motor up to 2500rpm's and createda similar problem by pushing the plate in the throat open to let in more air. This causes the motor to stutter similar to when I speed up to 2500's under a load.
If anyone has had a similar problem, please respond. The car has had a fuel pump replaced, plug wires, plugs, rotor, and cap.
Does the fuel distributor govenor have anything to do with this problem? I feel like this is something simple, but finding simple seems hard.

Loss in Savannah! HELP!!!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:45 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page