Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-06-2003, 09:25 PM
Posts: n/a
Question Power window blues...

Hi everyone!

During the blizzard I was trying to lower the left rear window on my 94 S500 (not smart - it was frozen)... Because it was frozen hard, a loud BANG came out of the door. After that the glass pretty much fell down into the door and now isn't suspended by anything, moves freely up and down by hand. I understand that it is the regulator, but may be somebody can tell me what I am looking at before I take the door apart. Could it be something that a machine shop could make? Don't want to replace the whole regulator assembly if it is only a linkage of some sort that broke...

Reply With Quote
Old 04-06-2003, 11:07 PM
Registered User
Join Date: Aug 2002
Location: redwood city,ca
Posts: 77
pw blues

The driver's door regulator in my 87 420sel parted with a loud bang one warm, sunny day. I took it out, and found a broken spot weld on the regulator. I bought a new regulator for about $80. I originally thought about having it re-welded, but decided against that, I can't remember why. Anyway,replacement was simple and quick. good luck
Reply With Quote
Old 04-06-2003, 11:52 PM
Posts: n/a
Regulators are cheap and after you replace it once you will probably never replace it again.
Reply With Quote
Old 04-07-2003, 10:39 AM
Thomaspin's Avatar
Join Date: Jun 2001
Location: CA
Posts: 531
In my case it was a $4 plastic slider.

I illustrated the fix on my 1983 300SD on my web site.

Go to Cars - Technical - Chassis and look for Window Regulator.

If you can get your door panel off (there will be more to unplug on your model) you should be able to do the repair. I dread to think of the cost of having a third party do this, not to mention the high probability of filty thumb prints everywhere.

No special tools required on my model.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:24 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page