Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-05-2000, 10:45 PM
Registered User
 
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
idle has been fluctuating and often times
stalls from STOP. recently changed the
fuel filter, fluctuating rpm and stalling now corrected, but sometimes idle speed sticks to higher RPM (800),when at "P"
position RPM shoots up to (1000). other times RPM stay normal. what is this telling me?? thanks


[This message has been edited by joel (edited 01-05-2000).]
Reply With Quote
  #2  
Old 01-06-2000, 09:56 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
This could be a common failure such as the throttle switch or the overvoltage relay. I would replace the overvoltage relay first. If that doesn't help, go to a tech for help.
Good luck.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #3  
Old 01-07-2000, 01:22 PM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,705
JOEL if you find out what the problem is please let us know here because I have the same problem on my M102 engine. I thought it might be the bowden cable which looks a little slack below the throttle cable. The throttle cable itself feels fine. I am thinking of replacing the throttle switch like Benzmac suggest, failing that i'll have to visit MB.
p.s. Try tapping the accelerator pedal slightly several times and see if the idle sinks.

yal
88 230e (W124)

[This message has been edited by yal (edited 01-07-2000).]
Reply With Quote
  #4  
Old 01-09-2000, 12:01 AM
Registered User
 
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
benzmac, thanks for the tip and immediate reply. cleaned airflow intake valve and float underneath air filter housing - problem disappeared!! hope it lasts.
where is the throttle switch located, anyway?

[This message has been edited by joel (edited 01-08-2000).]

[This message has been edited by joel (edited 01-08-2000).]
Reply With Quote
  #5  
Old 01-31-2000, 01:25 AM
Registered User
 
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
benzmac: my car is acting up again. RPM shoots up to 1000 when car in "P." where is the throttle switch located? thanks.
Reply With Quote
  #6  
Old 02-01-2000, 12:56 PM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,705
The throttle switch is behind the gas pedal. Right there on the mat. You can't miss it.
Reply With Quote
  #7  
Old 02-01-2000, 02:52 PM
Registered User
 
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
yal -
thanks for your reply. did you change your
throttle switch as you planned? did it fix your problem. thanks
Reply With Quote
  #8  
Old 02-01-2000, 10:02 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
No the throttle switch is located on the throttle body under the air cleaner. It is a skilled job. I'd allow a tech to do this.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #9  
Old 02-01-2000, 10:27 PM
Registered User
 
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
thanks benzmac. yal, i almost killed my dealer who insisted that it was the kickdown that is behind the gas pedal. cheers!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle speed too high lin Tech Help 2 06-11-2005 04:33 PM
The idle speed, should it vary? rbort Tech Help 0 03-09-2004 12:31 AM
Idle Speed - 1985 500 SEC awfrance Tech Help 10 01-31-2003 05:30 PM
Low idle speed. Jackd Tech Help 1 02-27-2002 01:09 AM
'83MB 300SD Idle Speed Wm. Lewallen Tech Help 2 04-24-2000 09:52 PM



All times are GMT -4. The time now is 10:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page