Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-11-2003, 08:42 AM
Posts: n/a
89 300e problems

Hello i am new to the site, i have a 89 300e my wife drives 147k and lately she say's when she comes to a stop sometimes the car just dies, after putting it in park or net. it starts right back up no waiting??? also sometimes the a/c system goes dead ( no blower, compressor, and the pannel seems dead) after a while it will work just fine, has anyone had any simular type problems, any help will be great, thanks, Mark
Reply With Quote
Old 04-11-2003, 07:04 PM
J.HIDALGO's Avatar
Registered User
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Is the monobelt adjusted properly?

It sounds like the alternator is not working right. Any lights? More symptoms!
'86 300E
Reply With Quote
Old 04-11-2003, 08:51 PM
Posts: n/a

Could be two unrelated problems.

First, the engine dying could be from a loose vacuum hose. My car was doing exactly the same thing. A vacuum line on the back of the engine was so bad it fell apart when replaced.

Time to do some serious vacuum hose replacements. Do them all. It will save you a lot of headaches. Some you should do on your own. Breather hoses on the valve cover and the idle control valve. Do a search on the above. You'll get lots of advice.

As for the ACC control, sounds like a bad solder on the ACC control unit. How are you with a soldering gun? Let us know.

BTW, I had the same ACC problems with my car. Re-soldering the board worked.

Reply With Quote
Old 04-14-2003, 07:42 AM
Posts: n/a
Thanks for the help, i will track down the vacume lines and replace, the a/c pannel you are refering to is the push botton pannel in the dash?. I am pretty good with a sodier gun, i used to own a jag ( lucas wiring) haha, the alt. seems to work fine no battery or light problems, thanks again, i will post after repair
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page