Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-11-2003, 09:11 AM
Registered User
Join Date: Apr 2003
Location: Israel
Posts: 5
Red face Convertible top electrical problem

i am having problems to open and close the soft top of 300SL 129 1992.
i have replaced in the past the control module (under the rear seat) which was quite expensive.
it worked for a while but now it doesn't seem to open and close just like before i replaced the module.
the switch flashes when pulled or pushed but nothing happens.
the roll bar doesn't work either. the windows work fine.
Please help
Reply With Quote
Old 04-13-2003, 03:47 PM
Registered User
Join Date: May 2001
Location: Las Vegas, Atlanta
Posts: 669
You should have one or more diagnostic codes stored in the soft top controller memory that will explain your problem. To read them, short pin #10 of the diagnostic connector to ground for three seconds and count the number of times the red lamp in the top switch flashes -- this is the first code. Repeat until you have all the codes. You can erase a code by reading it and then shorting pin #10 to ground for 8 to 10 seconds. If you post your codes, I will explain their meanings and suggest the next step.
Reply With Quote
Old 04-15-2003, 10:03 AM
Registered User
Join Date: Apr 2003
Location: Israel
Posts: 5
thank you, bobterry.
i did ground terminal 10, open the ignition and the red light in the button of the top doesn't flash., it stays on all the time as long as the ground is connected to # 10.
i checked all the fuses including ovp relay.
normally the light will come on only when crancking the ignition and as soon as it starts, the light will go off.
your reply is appreciated.
Reply With Quote
Old 04-15-2003, 06:03 PM
Registered User
Join Date: May 2001
Location: Las Vegas, Atlanta
Posts: 669
I don't think I know enough to help, but...

...try pressing the convertible top button for no less than 90 seconds continuously both directions and then check for codes again.

Regarding the roll bar, you might check if it has codes by grounding pin #7 for three seconds and watching a lamp or LED connected between pin #7 and ground.
Reply With Quote
Old 05-12-2003, 03:10 PM
arr320's Avatar
Registered User
Join Date: Aug 2002
Location: AL USA
Posts: 26
Exclamation wow

I have the same problem for quite some time. You can look at my post, bobterry99 and some other members gave me good testing procedures. I would still like to fix my top, if you get some good addvice send it down. Thanks!

2001 C320 Sport 17" AMG Potenza S03
1991 500SL 18" AMG Contysport
1993 190E 2.6 17" AMG Contysport
2002 G500
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page