Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-09-2000, 03:48 PM
David Hendy's Avatar
Registered User
 
Join Date: Jun 1999
Location: New Milford, Ct
Posts: 906
On my new 500E there is a K40 front andd rear radar detector mounted above the sunvisor. When I test drove the car it was working, but now I own the car I cannot seem to turn it on. There are two slide buttons on the front for volume and sensitivity, but they do not seem to turn the unit on. Any ideas?, right now I need the radar detector!!

David Hendy
'92 500E 59k miles
Reply With Quote
  #2  
Old 02-09-2000, 07:32 PM
Michael's Avatar
Veteran
 
Join Date: Jul 1999
Location: CT, USA
Posts: 2,699
Yeah, you sure do need your detector!! I'd start by looking for fuses...go to the fusebox under the hood and see if maybe they grabbed power for the detector there...if so, follow the line until you find its fuse.

If this fails, I'd start by pulling the trim panel under the dash, above the driver's knees...it's likely stuffed up in there.
I really don't know if the K40 even has a power switch...it may not. Boomer McLoud is a retailer here in New England; they sell K40s so I'm sure they can offer advice too. Good luck, and enjoy your Ride!!

------------------
Best regards, Michael
'92 500E
'88 300TE
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Not Working BeNzInIt83 Tech Help 12 10-18-2004 05:47 PM
turn signal problem after steering box R&R rvolheim Tech Help 3 06-07-2003 05:19 PM
Hot Start Problem -- 220 Will Not Turn over when Hot MBenz2 Tech Help 0 03-10-2003 07:29 PM
Turn Signals 83 300SD johnsue1 Diesel Discussion 2 09-19-2000 11:30 PM
Turn Signals mooch2 Tech Help 1 08-25-1999 12:37 PM



All times are GMT -4. The time now is 11:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page