Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-19-2003, 03:30 PM
First Mercedes
Posts: n/a
Top Speed Is 25 MPH!

Purchased an 84 300D about two weeks ago. The first time I drove it, I had trouble getting over 40 mph. After about 100 miles, I was cruising at 65 and 70. Three days later, it slowed down again, and I had it towed back home. I just added two quarts of Trans-X, after draining two quarts of tranny fluid. Drove it about 15 miles, which was a chore as, now, I can't get it over about 20 to 25. Could it be something other than the tranny? It seems to shift, and then bogs down. I can floor the accelerator, and it doesn't seem to matter. I switched to neutral, and the engine is definitely reving. Any ideas?
Reply With Quote
Old 04-19-2003, 06:06 PM
Registered User
Join Date: Apr 2003
Location: Malta, Europe
Posts: 54
i once had somthing similar on my '81 200
however i dont think it could be the same thing, cause mine is a carburated petrol engine and yours is, i presume, a direct-injected diesel?

anyway in my case it was a rubber diaphram in the carb. so every time i pressed the throttle, it wasnt actually working, thus max. revs were about 2,000 as opposed to the normal 6,000


could it be dirty injectors or something?
or.. a wild guess here.. a really, really clogged air filter? :Confused:
Reply With Quote
Old 04-20-2003, 07:21 AM
Registered User
Join Date: Mar 2003
Location: New England
Posts: 205
Start with new fuel filters, make sure the engine is god before going to the tranny.

Reply With Quote
Old 04-20-2003, 08:01 AM
Registered User
Join Date: Feb 2002
Location: Virginia
Posts: 550
Absolutely, check fuel filters first. If this car is new to you its a good idea to swap them out anyway, then keep a spare set in the trunk in case you get a bad batch of diesel. Make sure you replace both the inline filter and the spin on filter. If that doesn't fix it let us know. Also, how much smoke to you get when you floor it? and what color?

82 300 SD
77 450 SL (gone)
Reply With Quote
Old 04-20-2003, 03:05 PM
jbaj007's Avatar
Registered User
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
Check all of the accelerator linkage from foot (pedal) to IP. Several listers have reported cracked linkage plastic parts and the lack of full travel on the linkage. Fuel filter change out. Algae check at tank outlet line.
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote
Old 04-21-2003, 12:19 AM
Registered User
Join Date: Apr 2002
Posts: 3,469
Try checking from the firewall to the injection pump, that broke on me one time. I dont really know what it is called though.
No Benzes in the stable at the moment, but itching for one again.

Former Mercedes in the Stable:
1983 300CD Turbo diesel 515k mi sold
1984 300CD Turbo Diesel 150 k mi sold
1982 300D Turbo Diesel 225 sold
1987 300D Turbo Diesel 255k mi sold
1988 300 CE AMG Hammer 15k mi sold
1986 300E Amg Hammer 88k mi sold
1992 500E 156k mi sold
Reply With Quote
Old 04-22-2003, 12:12 AM
First Mercedes
Posts: n/a
Rockin' & Rollin' Again!!

Changed both filters and added a can of Gumout Diesel Injector Cleaner. She's running like a champ now! Will do the 0-60 time trial to confirm turbo boost. Thanks to all of you!
Reply With Quote
Old 04-22-2003, 12:26 AM
haasman's Avatar
Registered User
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,096
Thanks for the update. Good news!

'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:57 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page