Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-22-2003, 01:28 AM
Registered User
Join Date: Apr 2003
Location: Vancouver, BC Canada
Posts: 19
Fogged front windshield

I recently bought my 1991 300e, and I noticed that when I return to the car the front windshield is fogged. It clears immediately and is never fogged while the car is running. The fogging only appears after I park the car for about 15 to 30 mins.

I have owned over 20 cars and never experienced this. Are any other 300e owners experiencing the same? Could this be an early warning sign of a bigger problem?

Thanks in advance.

1991 300E
1980 BMW 528i
Reply With Quote
Old 04-22-2003, 08:09 AM
thebern's Avatar
Registered User
Join Date: Jan 2002
Location: Knotts Island, NC
Posts: 382
Could be....

a water leak into the interior. Check the floor mats for dampness.

1982 240D 313,000 (4 speed)
1984 300CD 172,483
1985 German Shepherd Dog -Lacey- R.I.P.11/04/05

Hood Stars, Wrist Crowns and Obsession Dobs
Reply With Quote
Old 04-22-2003, 09:33 AM
Posts: n/a
If the fog is sort of oily or slimy it could be a leaking heater core. If it is pure water, then like the previous poster said, there is moisture in the interior.

If it is only moisture, check for water under the mats and ensure that the condensation drain is not plugged.

Good luck,
Reply With Quote
Old 04-23-2003, 01:43 AM
Registered User
Join Date: Apr 2003
Location: Vancouver, BC Canada
Posts: 19
The moisture is very light. There is no evidence of oil. It evaporates almost immediately.

I will try your suggestion to check for moisture on the mats. It may just be moisture on the mats. Living in Vancouver with all its rain, and my short trips, I may have tracked in a bit of moisture.

Its funny that I have never noticed it on any of my previous vehicles.

I will keep an eye on it. Thanks guys, for your input.

1991 300E
1980 BMW 528i
Reply With Quote
Old 04-23-2003, 02:03 AM
haasman's Avatar
Registered User
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,096
Our 91 300E does the same thing when the A/C was on right before turning the car off.

'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:47 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page