Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-29-2003, 08:50 PM
Registered User
 
Join Date: Apr 2003
Posts: 10
S500 Climate control unit

Neither the heat nor the air conditioning works in my 1995 S500. The clutch on the a/c compressor does engage. Does this mean that the Climate control unit has gone bad? The heat and air stopped working in the rear of the car some time ago. Now there is no air or heat in the front. If it is the control unit, how difficult is it to replace?
Reply With Quote
  #2  
Old 04-29-2003, 10:05 PM
Registered User
 
Join Date: Oct 2002
Posts: 188
Hi there:

I am not sure which control unit you have. Do you have the BIG LCD display unit or the older style unit where it is seperated into 3 panels with a turn wheel on each.

Does your unit come on? I mean do you have the red lights when u press the buttons? Does it seems to be working?

If the unit seems to be working, since you said no air, I assume you mean no air blowing out. Did you check the blower and the clower regulator? the blower regulator is a common fail item.

Also if the unit is working, u can run diagnostic tests and get DTC codes to find out what went wrong. Have you read "Jimf" web site? He have millions of information regarding S500, a C140 but. Its almost the same as W140 so not to worry. Let me try digging up his address...
Reply With Quote
  #3  
Old 04-29-2003, 10:09 PM
Registered User
 
Join Date: Oct 2002
Posts: 188
found it..

http://pages.prodigy.net/jforgione/MB_S500.html

goto point 15.

I also recommend you take a look at his cool harness. Its a easy plug-n-play to keep the engine cool.... needed on these big 140 if u use your car in a hot country.
Reply With Quote
  #4  
Old 04-30-2003, 05:34 PM
Registered User
 
Join Date: Apr 2003
Posts: 10
s500 heating and cooling

My unit has the two separate controls with the wheels that you roll to adjust the temp on the passenger and driver sides. I'm sorry I was misunderstood, but it does blow air just not at the correct temperature. The air is neither heated nor cooled.
Reply With Quote
  #5  
Old 05-01-2003, 03:02 AM
Registered User
 
Join Date: Oct 2002
Posts: 188
were you able to run the tests? results?? please post them.
Reply With Quote
  #6  
Old 06-02-2003, 08:09 PM
smetri
Guest
 
Posts: n/a
did you fix it

I'm also having the same issue with my car. When I ran the test, it did not come back with any error codes, just the features. Is there a common part that usually goes bad first?
Reply With Quote
  #7  
Old 06-02-2003, 10:05 PM
Registered User
 
Join Date: Apr 2003
Posts: 10
No I haven't repaired it yet. I don't want to spend the big bucks on the climate control until I'm absolutely sure it's the climate control.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page