Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-30-2003, 11:43 AM
Rod Rod is offline
Registered User
Join Date: Apr 2003
Location: Sunset, Louisiana
Posts: 57
S420 AC Works great, quits, works again, quits again

My wife's 1989 S420 AC has started to fail at times. I had the freon checked and it's fine, the R-12 system has started to quit working. One moment it's cooling at 42 degrees, then it quits. The next time I start the car the AC works great. Two days pass and everything is fine, I head in to town and the AC quits again cooling. The compressor does stop spinning when the AC stops working. As long as the Compressor is working, the system works great. Yesterday the temp outside was 85 degrees as I started it and it did not work. Later while the car was still hot and the AC works great.
Reply With Quote
Old 04-30-2003, 02:49 PM
1994C220's Avatar
Registered User
Join Date: Aug 2001
Location: Iowa City, Iowa
Posts: 124
98 ML320 with same problem


Ive got the same problem with my wife's ML. I have been working at narrowing the problem. Same symptoms...Ive gotten several possibilities from an evaporator temperature sensor, to the control unit...Those are two possilities you can check.

I thought it might have been the control unit, but from what I see happening now, the AC will act up even when I dont mess with the controls at all. I want to know if anyone knows how to test the evaporator temperature sensor? If there is a way to test it.
1994 S320
131K miles

1998 ML 320
126K miles

1994 Blue C220
122K miles

Im going to Grad School @ the University of Iowa
Go Hawkeyes!!!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page