Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-01-2003, 02:24 PM
85-190E
Guest
 
Posts: n/a
Unhappy NEED HELP .....190E fuel pump problems

Here is the ultimate 190E problem.....

I have a 190e 2.3that will start and die immediatly I took out the Fuel pump relay and bypassed it runs great without the relay.
I bought a fuel pump relay and it did not fix the problem.... back to square one....I have checked every fuse in the car and checked all wires going to and from the relay location. I have power to all areas of the relay that I can tell. The shop CD I have is no help.

Can anyone tell me if there is another input to the fuel pump relay that might affect the relay not starting the pump?

Has anyone heard of a similiar problem?

Any suggestion out there would help...I do not have a Benz dealer in my area so I am on my own......

Thanks
EK
85-190E

Last edited by 85-190E; 05-08-2003 at 05:09 PM.
Reply With Quote
  #2  
Old 05-01-2003, 04:03 PM
sunil190e-1.8's Avatar
Registered User
 
Join Date: Jun 2002
Location: uk
Posts: 236
are you sure the new fuel pump relay is working?

was it new or used?

check you ovp relay fuse/s
Reply With Quote
  #3  
Old 05-02-2003, 10:02 AM
85-190E
Guest
 
Posts: n/a
Thanks for the reply
The relay is new and I have power from the OVP.. I had bought a new OVP just in case
Reply With Quote
  #4  
Old 05-08-2003, 05:06 PM
85-190E
Guest
 
Posts: n/a
Has anyone run into a fuel pump issue thats sounds close to my 190E problem......
Reply With Quote
  #5  
Old 05-08-2003, 07:02 PM
MTI's Avatar
MTI MTI is offline
Registered User
 
Join Date: Nov 2002
Location: Scottsdale, Arizona
Posts: 10,626
Not sure if this will help, but in addtion to the fuel pump relay and the CIS control unit, the 2.3 does have a "cold start valve" on the intake manifold and a "fuel distributor governor" nearby. Wouldn't hurt to visually inspect the connections there. Good Luck and keep us updated on any finds.
Reply With Quote
  #6  
Old 05-10-2003, 11:47 PM
ljc01
Guest
 
Posts: n/a
fuel pump relay

Yes, I had a very similar problem with my 85' 190E. It is both your fuel pump and your relay. The pump is shorting out your relay. I went through several relays before we found this out. When your relay goes it either stalls after starting or starts hard. The relay has two settings for cold start and normal running. The cold start is working to start the car but then it switches to normal running and stalls. I restarted the car so many times before I realized what was wrong that I snapped the ignition switch which locked in the start position and ruined the starter and the fly wheel. $1800 later it was still stalling. Then we replaced the fuel pump and relay and never had a problem again. The relay also controls your cruise control because that worked again after we replaced it. Good luck! -Lj
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page