Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-03-2003, 01:08 PM
dnthomas's Avatar
New MBOwner in 2002!
 
Join Date: May 2002
Location: Mississippi
Posts: 44
Question A little help please.....

I am out of town and my wife just called, says the battery, ABS and check engine lights came on when returning from a short trip to the store.

Two weeks ago I had the rear rotors replaced with new ones and new pads etc., I have also recently done the brakes on the front.

I also bought new tires about two weeks ago.

Any ideas or suggestions?
Attached Thumbnails
A little help please.....-front3.jpg  
__________________
D. Thomas
1991 560SEL
New Owner as of 05/25/2002, first MB!
http://www.bellsouthpwp.net/d/n/dnt0512/1991.htmL
Reply With Quote
  #2  
Old 05-03-2003, 02:25 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
Sounds like your alternator is going out.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #3  
Old 05-03-2003, 03:24 PM
dnthomas's Avatar
New MBOwner in 2002!
 
Join Date: May 2002
Location: Mississippi
Posts: 44
Correction

she just advised me that the check engine light is not on it is the Brake light, ABS light and the battery light.

I should have said this is a 91' 560SEL

Thanks in advance for all replies.
__________________
D. Thomas
1991 560SEL
New Owner as of 05/25/2002, first MB!
http://www.bellsouthpwp.net/d/n/dnt0512/1991.htmL
Reply With Quote
  #4  
Old 05-03-2003, 03:56 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
Alternator.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #5  
Old 05-03-2003, 04:27 PM
dnthomas's Avatar
New MBOwner in 2002!
 
Join Date: May 2002
Location: Mississippi
Posts: 44
suginami,
Thanks a million! I appreciate your willingness to help, thanks again, I will have her get the alternator checked and replaced if necessary.
__________________
D. Thomas
1991 560SEL
New Owner as of 05/25/2002, first MB!
http://www.bellsouthpwp.net/d/n/dnt0512/1991.htmL
Reply With Quote
  #6  
Old 05-03-2003, 06:06 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,743
Could be just the regulator in the alternator. Side-of-the-road-with-a-screwdriver job if you can get under the car... and have a replacement regulator.

Check Thomaspin's website for details on replacement. Do a search on any post by Thomaspin. There's a link in his sig line.

There's a good chance it will quickly go downhill once the dash lights come on. I would not try to go more than 10 miles in this condition.

Sixto
91 300SE
87 300SDL
83 300SD
Reply With Quote
  #7  
Old 05-03-2003, 06:10 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
With that year car it could be perfect timing for another battery. Does it have water?

Is the altenator belt tight? An easy way to check is to reach down and try and turn it (engine off of course!) and with the engine cold.

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #8  
Old 05-03-2003, 09:13 PM
Blu 420Sel's Avatar
Registered User
 
Join Date: Feb 2003
Location: Connecticut
Posts: 274
Pretty sure this will fit:

http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&category=33577&item=2413167064&rd=1

Its a very easy fix.
__________________
1988 420SEL 170K
Reply With Quote
  #9  
Old 05-04-2003, 02:30 PM
dnthomas's Avatar
New MBOwner in 2002!
 
Join Date: May 2002
Location: Mississippi
Posts: 44
Thanks for all replies!

I am going to try the regulator first and then the alternator. I am also gonna check on the battery although I think it is less than 5 years old.

Thanks again
__________________
D. Thomas
1991 560SEL
New Owner as of 05/25/2002, first MB!
http://www.bellsouthpwp.net/d/n/dnt0512/1991.htmL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page