Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-06-2003, 10:56 AM
Registered User
Join Date: Jan 2003
Posts: 8
A/C prblm chklist

my 94 s420 ac is not working, can someone give me some ideas on what to check, are there common problems with the ac on this model year? if so what are the problems.

so far:
blower works at all speeds,
sufficient freon

Reply With Quote
Old 05-06-2003, 12:18 PM
Registered User
Join Date: May 2003
Posts: 62
Im surprised that your freon checks out because the 140 chassis usually has a problem with the evaporator leaking. Well what isnt the ac doing ie engaging the compressor clutch. IF that is the case i would check that the clutch is getting power when you engage the ac system. If it is not which is probably the case work your way up the system. I would also chech the etr if that is telling the ac system that the evaporator is too cold then it wont turn the ac compressor on either. There is a way to go into self diagnosis with the acc but i forgot because at the dealer we would just use the hht. Sorry for not being more specific.
1982 300D Turbo (Mom's)
1993 BMW 525I (Dad's)
2001 Vw Golf (Brothers)
2002 Nissan Ser SpecV (Im the Black sheep lol)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page