Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-20-2000, 11:35 PM
corkyb
Guest
 
Posts: n/a
The heater in my 380sl seems to only work in town at low speeds. Once the engine warms up, and the speed increases such as highway speeds, the heater blows cold no matter what the setting is. Once you slow down as in stop and go traffic, or if you turn the car off, let it set a few minutes then restart it, the heater blows hot, until you reach high speeds again. I have checked the heater control valve, and it opens and closes. ( I have even disconnected it and the heat still doesn't work right.) I have also checked and replaced the aux. water pump. Any suggestions and help would be appreciated.
Thanks in advance.
Reply With Quote
  #2  
Old 02-21-2000, 11:40 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Have you replaced the mono-heat valve insert?? IF not do it first. They are all bad if more than a year old. The rubber leaks and rips causing liquid lock under pressure.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #3  
Old 02-22-2000, 09:28 PM
corkyb
Guest
 
Posts: n/a
Hi, thanks for your quick response. Would this be the same as the heater control valve. (Located on the passanger side firewall?)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater woes - problem solved, cost 15 cent fuhshingpan Diesel Discussion 0 01-20-2005 03:34 PM
Yet another heater problem tenknots Diesel Discussion 1 12-06-2004 11:51 AM
accessing heater hose clamps -380SL rstarkie Tech Help 0 01-03-2003 05:41 PM
A/C and heater problem Jackd Tech Help 26 10-31-2002 05:28 PM
84 mercedes 380SL Fuel injection problem outkast Tech Help 0 05-21-2001 01:59 AM



All times are GMT -4. The time now is 01:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page