Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-07-2003, 12:26 PM
Registered User
Join Date: May 2003
Posts: 2
Angry Air conditioning

I have a 1998, 300TD. Sometimes when I get the air-condition started, it works fine, but later the same day it stops working. I will be on the road and the air start working after 20 minutes of drive. When it works it is fine otherwise it is just like the EC botton is pushed and just recyles outside air.

Any idea???

Reply With Quote
Old 05-07-2003, 01:10 PM
it leaks, its german
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
get a sds hooked up and check the evap temp sensor and the refridgerant temp sensor checked out.

Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
Reply With Quote
Old 05-07-2003, 02:00 PM
Registered User
Join Date: May 2003
Posts: 2
Thanks Joe.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:48 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page