Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-07-2003, 10:31 PM
Plantman's Avatar
Registered User
 
Join Date: Jan 2003
Location: Miami
Posts: 2,133
Starter or ignition switch

My 85 300SD has been running like a champ lately.

The only problem that has occured that has me puzzled is this;

I shut it off after a short ride and got nothing but a click when I went to start her up. Prior to the short ride I had been in and out of it all day and no problems.

Car was in park, even tried in nuetral and it had plenty of juice.

Called AAA and got towed home.

Car started right up. Tried it a couple of times and she cranked up fine. AMybe it likes my house better than downtown Miami.

Any ideas would be appreciated.

Thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page