Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-15-2003, 03:26 PM
mike690003's Avatar
Registered User
 
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
300e idles smooth, then "coughs"

Hello Board, I have and 87 300E(146k miles). It recently had a "new"(89k miles) engine installed into it (form an 89 300e). I have done the plugs,wires,cap and rotor,voltage regulator and it seems fine. The one problem is that it idles fine, and then it sort of coughs. The exhaust also smells of raw gas,my gas mileage is bad(about 10-12 mpg). The car also has bad cold and hot strat problems, Is my cooland temp sensor at fault?, if so, where is it located on the 89 engine? any other suggestions to what can be causing these problems?

please help!
Reply With Quote
  #2  
Old 05-15-2003, 07:17 PM
inspector1
Guest
 
Posts: n/a
Raw gas out the exhaust indicates a extremely rich condition, scope the O2 sensor to begin with, or just replace it. Check the timimg.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page