Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-15-2003, 03:32 PM
mike690003's Avatar
Registered User
 
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
300e dash dims and brightens, help!

Hello Board, My 300e is experiencing a problem that is driving me nuts! When I first start it up(at night) the dash is bright and after driving around for 5 minutes, the dash is yellowish, and not as bright as it should be, also my radio blinks with the volume turned up and when I open the drives door, the dome light flickers. I replaced the voltage regulator and the dome light bulb already and i have checked all my fuses(they are good). what could my problem be??
Reply With Quote
  #2  
Old 05-15-2003, 05:52 PM
DuckMuck's Avatar
Feathered Member
 
Join Date: May 2000
Location: Chandler, Arizona, USA
Posts: 804
Arrow

alternator?
__________________
1995 black pearl/black Mercedes-Benz E420 :
Reply With Quote
  #3  
Old 05-15-2003, 06:36 PM
Thomaspin's Avatar
pindelski.com
 
Join Date: Jun 2001
Location: CA
Posts: 531
Not sure if the 300E has one....

....but have you checked the rheostat (dimmer) control on the instrument panel? These get dirty with use and intermittent contact can cause your symptoms.
Reply With Quote
  #4  
Old 05-15-2003, 07:05 PM
inspector1
Guest
 
Posts: n/a
Since you replaced the regulator, I would suggest you check that for proper installation and function 'cause your symptoms are indicative of a faulty alternator, there is a slim possiblity that the part was defective when you bought it. Might also check battery cables/terminal connections for cleanliness and a tight fit
Reply With Quote
  #5  
Old 05-15-2003, 07:19 PM
mike690003's Avatar
Registered User
 
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
Alternator?? I have no dead battery problems! Any other culprits??
Reply With Quote
  #6  
Old 05-15-2003, 08:22 PM
DuckMuck's Avatar
Feathered Member
 
Join Date: May 2000
Location: Chandler, Arizona, USA
Posts: 804
Exclamation

This is what I am thinkin'...if the alternator was dead, or very close to dead...obviously, you will have a dead battery after a while, which makes sense...but in your case...it seems the alternator is not quite providing enough amps/not performing up to specs and is almost on its way out...so although it is still charging the battery and powering your car electronics, it seems to be really struggling when you turn up the volume on your stereo, or keep the headlights running, etc. The battery is still being charged though...but maybe not being fully charged...but enough for starting the car, etc.

One way to test is to drive around your neighborhood for 5 minutes or so, until you see your headlights dim down as you described...and have the radio volume up or whatever electrical drain that you have in your car...then, pull over to the curb...put the car in park...and rev the engine up high...see if the lights come back up in brightness...
__________________
1995 black pearl/black Mercedes-Benz E420 :
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page