Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-16-2003, 03:13 PM
Posts: n/a
300e Srs Light

I have 1990 300E, 3.0 Benz. Recently, I started getting SRS light intermittently. What are things that can cause this? Please help.
Reply With Quote
Old 05-16-2003, 03:28 PM
bd37703's Avatar
Registered User
Join Date: Jul 2002
Location: Maplewood, NJ
Posts: 68
I had this happen to my '91 300E as well ..... it came on and "stayed on" a few times over couple of days .... now it comes on when I start the car and then the SRS light doesn't stay on - which is normal behavior ..... I don't know what fixed it!
'91 300E 3.0L / 138k / Pearl Black / De-badged / 16x7.5 Mille Miglia Bello Wheels / S600 grill / Euro Headlights / Smoked Corners / Smoked & Red Tail Lights / Bilstein Shocks / K&N Air Filter / Sony Xplod / Connected IPOD
Future Upgrade(s): Stainless Steel Brake Lines

Last edited by bd37703; 05-16-2003 at 04:46 PM.
Reply With Quote
Old 05-20-2003, 09:43 AM
Registered User
Join Date: Jul 2001
Location: Kingston, Ont.
Posts: 201
Im hsaving the same problem and a search has revealed two possible causes:

1) contact points on the steering column are getting dirty or worn, requring some diy removal of steering wheel to get to the afflicted part.

2) poosible voltage over or under charging.
Reply With Quote
Old 06-13-2003, 11:53 AM
Posts: n/a

1. How do you check steering column?
2. Do you think under-charging may be due to loose belt or tensioner problem?
Reply With Quote
Old 06-13-2003, 10:23 PM
Registered User
Join Date: May 2000
Location: Scotts Valley, CA.
Posts: 145
SRS light

In my '89 300E, I had that happen and a few minutes later the car started dying... It turned out to be the voltage regulator had blown. Simple fix, not too expensive.

I had a similar type of occurrence as bd37703 in our 1992 190E (2.3) and it turned out to be the OVP (over voltage protection)relay. Not too expensive (around $75) a bit of a pain to do (helps if you have small hands like I do) but only took about 1/2 hour one Friday evening.
Jay Yambrovich
Scotts Valley, CA.

1993 300 CE Cabriolet (A124) 131K miles
1997 C-280 133K miles

2000 BMW R1100RT 69K miles
1989 300 E 216K miles (sold)
Reply With Quote
Old 06-16-2003, 05:14 PM
Posts: n/a
Thanks a lot. I will check & let you know.
Reply With Quote
Old 06-16-2003, 05:17 PM
drbrandini's Avatar
Join Date: Sep 2001
Location: Wrightsville Beach NC
Posts: 1,512
Sounds like an OVP problem.

Good Luck!

2008 S550
1957 Dodge D100
1967 VW Microbus 21 Window
2001 Suburban
2004 Beach cruiser bicycle
-----------------GO DUKE!-----------------

"It cannot be emphasized too strongly or too often that this great nation was founded not by religionists, but by Christians; not on religion, but on the Gospel of Jesus Christ. For that reason alone, people of other faiths have been afforded freedom of worship here." Patrick Henry 1776
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page