Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-19-2003, 10:33 AM
sms sms is offline
Registered User
Join Date: Dec 2001
Location: Hartford
Posts: 134
560sl 10p17c compressor

My 560sl a/c compressor has failed. I believe from the looks of things that it's simply the seals that have gone bad. Compressor is not seized and don't see any signs of metal particles in the discharge ports of the compressor. Compressor is caked-up with oil and attached dirt.

I'm replacing the compressor and am not sure where the oil is put in? Do you add it directly to the compressor or to the system during the charge-up with r-12?

Also, I'm considering flushing the system, but don't know where the expansion valve is located? Is it behind the glove compartment box?

Lastly, I'd like to install a suction side filter. Can that spliced by me or is it something that must be done at a shop?

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:14 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page