Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-19-2003, 02:41 PM
Registered User
 
Join Date: Apr 2003
Location: Richardson, TX
Posts: 92
E320 (W210) Intermittent Starting Problem

I'm having intermittent problems with my E320 cranking but not starting. It has also stalled twice, once at a stoplight and once in a slow turn. No check engine lights.

The pattern I've observed is that it starts fine when it is cold, but after it has been driven for a while (e.g. 10 mi), it will not start again unless it cools down for at least a couple hours. When I drive it, it runs smooth, with the exception of the two stalls. But then again, I let it sit for a few hours and then it starts fine.

The first thing I tried was a new fuel pump relay, but that didn't make a difference.

Any ideas?
Reply With Quote
  #2  
Old 05-19-2003, 10:50 PM
Southern's Avatar
Registered User
 
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
Have you replaced your fuel filter? Mercedes recommends replacing the fuel filter and air filter at 60K miles. They also recommend replacing the spark plugs at 4 years or 100K miles (which ever comes first).

The fuel filter for this car is not cheap - it has a built in fuel regulator.
__________________
Ray
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
  #3  
Old 05-19-2003, 11:29 PM
Registered User
 
Join Date: Apr 2003
Location: Richardson, TX
Posts: 92
The fuel filter was replaced about a month ago when I did the 60K service. The spark plugs are on my to-do list.
Reply With Quote
  #4  
Old 06-03-2003, 10:33 PM
Registered User
 
Join Date: Apr 2003
Location: Richardson, TX
Posts: 92
Update:

Problem solved. Took it to my mechanic and he replaced a knock sensor.
Reply With Quote
  #5  
Old 06-13-2003, 01:01 PM
Registered User
 
Join Date: Nov 2002
Location: Austin, Texas
Posts: 179
Where is the fuel pump relay located on W210, I have 97 e320

Thank you
Reply With Quote
  #6  
Old 06-14-2003, 11:31 PM
Registered User
 
Join Date: Apr 2003
Location: Richardson, TX
Posts: 92
The relay is in the fuse box beside the battery, underneath the rear seat. MB part number 02 542 13 19.
Reply With Quote
  #7  
Old 06-15-2003, 03:43 AM
Registered User
 
Join Date: Nov 2002
Location: Austin, Texas
Posts: 179
benzthere

Thank you very much
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page