Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-20-2003, 04:23 PM
mike690003's Avatar
Registered User
 
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
300e jumps out of gear too fast

Hello board, I have a concern with my 1987 300e transmission.The tranny was rebuilt by the dealer four years ago, I downshifts great in highway traffic and it shifts smoothly.What concernes me is that I was pulling out from a stop sign to merge into in to heavy traffic. I stomp my gas to merge and the tranny starts to accelerate and then flattens out, as if going into a higher gear. This almost cost me the rear of my car, luckily the driver slowed down. Well I know these cars arent speed demons, but my sisters' ford focus cand pull into traffic quicker than my 300e. I lubricated my cables but that only helped a little. Could there be a problem with my bowden cable??Is it a DIY thing? Help
Reply With Quote
  #2  
Old 05-29-2003, 08:00 PM
mkpeters
Guest
 
Posts: n/a
You might want to check on you vacuum line from the modulator to the manifold. Does the trans have a hard time going from 2 to 3 or 3 to 4'th ?

Clean out the line and plug it back in and I would be suprised if it didn't fix your problem.
Reply With Quote
  #3  
Old 06-05-2003, 04:21 PM
mike690003's Avatar
Registered User
 
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
it turned out to be a broken kickdown switch. $14 fix
__________________
1987 mercedes 300E
1995 e320 conversion(hated the 300e grill)
HID/Xenon (D2S)
Keyless Entry
Monochromatic Paint (Custom Blue)
Smoked Tails
Flat Badged (front)
Debadged (rear)
custom "carbon fiber" console
18 inch HP EVO rims
Sold! Now I drive a Monte Carlo SS
http://memimage.cardomain.net/member.../352975_67.jpg
http://memimage.cardomain.net/member.../748335_24.jpg
Reply With Quote
  #4  
Old 06-06-2003, 02:04 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
mike690003

Glad to hear you found the fix. Just curious, how did you know it was the kick down switch?

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page