Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-21-2003, 07:30 PM
Registered User
Join Date: Apr 2003
Location: NC, USA
Posts: 112
Question all three lights on dash light up

Every time i start my car (1982 300D turbo) I have the alternator, brake wear sensor, and parking brake lights come on and stay on until I accelerate a little and bring the RPMs up. While I'm at idle at a light or stop sign or simular situation I notice my alternator light is dimily lit until I accelerate again. I checked the alternator belt and it checks fine and the other two lights do NOT come back on until I have a cold start after glow plug time out. Am I missing something or should I adjust my idle speed a little to extinguish the lights?
Reply With Quote
Old 05-21-2003, 08:56 PM
sixto's Avatar
smoke gets in your eyes
Join Date: Jun 2000
Location: SF Bay Area
Posts: 18,745
I think your alternator is slowly coming to the end of its life. A new regulator might do it, but I get the feeling it's just plain worn.

91 300SE
87 300SDL
83 300SD
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page