Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-22-2003, 09:22 PM
Registered User
Join Date: Nov 2001
Location: west orange, NJ
Posts: 47
switch illumination

On my 1991 560 SEL, the illumination on 2 switches does not work. They are the rear defrost switch and rear dome light. All other switches illuminate fine. I replaced the switches thinking they had burned out bulbs but they still don't work. I noticed that both switchjes have what looks like a fibre optic cable which probably provides they illumination. Question is, where is the light source(s) located? Anybody know?
Reply With Quote
Old 05-22-2003, 10:55 PM
handsworth's Avatar
420SEL "Big Boy"
Join Date: Jul 2001
Location: Suburban Cleveland, ohio
Posts: 117
You are right about the thin cables that supply light to the switches and sorry I don't know how they work but on a 86 420SEL that I was parting out, once I had removed the center console, the radio and the climate control unit I saw the connections hanging right there. It was one main cable that branched off into several little ones. I really believe it was driven by a light source (bulb). Not sure if you really need to remove all these parts to get to it, but its right behind the CCU.
Reply With Quote
Old 05-23-2003, 12:31 PM
sixto's Avatar
smoke gets in your eyes
Join Date: Jun 2000
Location: SF Bay Area
Posts: 18,745
handsworth is exactly right. There's a spider looking thing behind the ACC control panel. A bulb is pressed into the head of the spider illuminating each of the legs. If any of the console switch lights or ashtray light work (hazard switch has its own bulb) then the fiber optic filament probably fell off from the switch or got kinked.

If it's the bulb, I think you can get to it by pulling only the radio but you'll be working blind. With the radio out, it's only a couple more screws to pull the console panel.

91 300SE
87 300SDL
83 300SD
Reply With Quote
Old 05-23-2003, 12:46 PM
Registered User
Join Date: Nov 2001
Location: west orange, NJ
Posts: 47
Switch Illumination

Thanks guys,
I'll pull the switches and console again and check out the FO cables to the source. Prior owner had an aftermarket CD installed which means someone was screwing around behind the panel. Hope they didn't damage the FO cable. Strange thing is, I can't seem to find the FO light source on any of the wiring diagrams.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:15 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page