Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-23-2003, 12:30 PM
Registered User
Join Date: May 2003
Location: Central NJ (@the beach)
Posts: 1
AC blows cold, but compressor never stops!

Hello All,
I have a 1986 300e that has some issues. Last year I changed the system over to 134a and it worked flawlessly for the whole season. That winter I drove to FL (from NJ) and while there noticed it wasnt working. This spring I checked the system and found it to be low, not empty, so I evac'd the remaining charge and put a vaccum to it, which held fine for well over an hour. I charged the system and now it will not cycle off, the compress functions well though and the cars interior is cooled rapidly. Besides not cycling the compressor is a little noisy at highway speed (3300 rpm) after about ten minutes or so (a high pitched whine). I emptied the system and replaced the low side switch with no results. I am concerned that if I continue to use the AC it will harm the compressor so I have discontinued use. I have tested the belt slip and temp cutoff relay (labeled KILMA) and both cut out functions are fine. The compressor does not run when the pushbutton selesctor is on economy (which is normal ) so I assume it isnt the climate control "brain" Does anyone have nay suggestions?
1974 BMW 2002 (Heavy use show car)
1986 Mercedes 300e (Driver)
1994 Mustang Cobra (Domestic Junk)
Reply With Quote
Old 05-24-2003, 02:09 AM
JimF's Avatar
'94 S500: only 793 sold!
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,924
Greg, read this . . .


Did you replace the OIL???? Hope so.

My compressor started to have 'strange' noises that was its death knoll.
Regards . . . . JimF
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:06 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page