Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-27-2003, 06:53 PM
Posts: n/a
Question 400 SEL lacks pick up and power

Can anyone help me with this? I am new to this group and need some advise. My 93 400SEL has no pick up at all. It boggs down when I accelerate, but when it finally does kick in, it flys. Doen anyone have any ideas as to this problem? I did have a tune up incl. new distributor caps about 3,000 miles ago. Thanks for your help guys..Chuck
Reply With Quote
Old 05-27-2003, 07:30 PM
Registered User
Join Date: Feb 2003
Location: Ontario, Canada
Posts: 3,160
Lots of questions come to mind:

1. Did the tune-up include a new fuel filter?
2. Do you have a " Check Engine " light on ?
3. Has anybody checked the fuel pressure ?

I think we need more details.
2007 C 230 Sport.
Reply With Quote
Old 05-28-2003, 12:01 AM
Posts: n/a
Hey, thanks for the reply.... No, the fuel filter was not replaced, there was no check engine light on, and there was no fuel pressure check. I think that I can handle the fuel filter change, but I need the location... would that be a good starting place? Thanks again for your reply, Chuck
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:11 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page