Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-28-2003, 01:59 PM
Registered User
Join Date: May 2003
Posts: 1
E300 will not start

Over the past few months my 98 E300 Turbodiesel has given problems starting. Now it is dead, will not start at all, I suspect it is a glow plug problem. This is my fourth diesel and I have never had a glow plug problem that is like this, although I did have the very same symptoms with a VW diesel.

What is the procedure for removing the manifold and installing new glow plugs? What are torque specs for glow plugs, manifold, etc?

Any help will be most appreciated.
Reply With Quote
Old 05-28-2003, 02:20 PM
G-Benz's Avatar
Razorback Soccer Dad
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Welcome to MercedesShop. Hope we can be of help to you as a new member.

A lot of "specialty" model members have forums as well, to sort out their particular issues.

Try posting this thread in "Diesel Discussion"...probably will get a quicker response.
2009 ML350 (84K) - Family vehicle
2001 CLK430 Cabriolet (71K) - Wife's car
2005 BMW 645CI (124K) - My daily driver
2012 Mustang V6 (60K) - Daughter's car
Reply With Quote
Old 05-28-2003, 02:54 PM
Registered User
Join Date: Jun 2000
Location: Plano, TX
Posts: 2,476
How is the car behaving that leads you to believe it has glow plug problems?

- JimY
Reply With Quote
Old 05-28-2003, 04:46 PM
blackmercedes's Avatar
Just a guy
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
It does sound like the infamous 606 glow plug problem. Our 98 E300 went through a couple sets, but they were covered under the warranty, so I can't help with the procedure, but I seem to remember someone DIYing it here, so you might try searching...

Good luck!
John Shellenberg
1998 C230 "Black Betty" 240K

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:28 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page