Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-30-2003, 08:32 AM
msethk's Avatar
Registered User
Join Date: Mar 2002
Location: Tucson, AZ
Posts: 293
94 c280 asr light starting problems

having starting problems with my 1994 c280. Car seems to start fine under cold start conditions but once the car has been run even for 5 minutes. the car seems like it is flooded but there is no fuel smell. the car will turn and turn and turn. it does eventually start but it can take up to 15-20 minutes to start and when it does it just starts. it never sounds like it is trying to start., just does. told could possible be mass air sensor or fuel injectors.also having problems recently with asr light coming on. it seems very random, but it has come on both of the last two mornings?

thanks for any help
1994 C280
2009 VW Tiguan
1993 Toyota X-tra Cab SE-5

1973 220D ... Gone, but not forgotten
1991 Alfa Romeo 164L Gone, wife MADE me forget it

2006 Hyundai Tucson... just straight out FORGOTTEN!

Last edited by msethk; 06-03-2003 at 02:19 PM.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page